C130s not arriving even though I have purchased the route

I purchased a route for C130 but they’re not arriving.
Why? :frowning:

The top issue was solved. All i needed was a large cargo stand.
But for some reason virgin atlantic flight isn’t coming no matter what I do.
Airport is Nagoya, i have all stands.

Another update :slight_smile:
The flight from virgin atlantic finally arrived, but a USPS Flight is refusing to arrive.

On which airport does this happen?

1 Like

Have you bought a cargo stand?

1 Like

An L cargo stand at that, even though it looks like an M-plane.

I figured it out, but i needed to buy the large cargo stand. But now the same thing’s s happening with the virgin atlantic flight, the airport is Nagoya

What exactly does it say? I mean is there “No arrivals available” ?

Yeah, thats what it says…and I’ve checked all the planes thats in my aiport at that moment. No sign of the Virgin atlantic flight either

Please can you post a screenshot?:wink:

Sure, gimme a few seconds! :slight_smile:
Also…the virgin atlantic flight arrived, but I noticed a USPS flight is also refusing to arrive. Should i just try to wait?

It sometimes feels like the number of planes is limited, I don’t know how to say it else. I noticed that too in NGO and don’t know if it happen in other airports.

Try it.:smiley:

But then the developers are screwing up the game…imo

Tried waiting…didn’t work

Have you purchased XL cargo stand (UPS 747CG)?

I’ve purchased also the c130s got XL and L cargo stands on Washington. Still never seen them.

Still haven’t landed? If not please post a screenshot. :wink: