Can'r entre the game

Hi, I have just downloaded the game, twice, and I can’t go from the welcome screen. It ask me to choose the Google play user and the stars again. A yo e knows what can it be?

1 Like

After Choosing my Google play user it appears a dialog that says SIGN IN, PLAYGAMES.

After I clic it, it stars again to look for the Google play conection. And agin asks me for my Google play user. If I clic outsidd of the dialog an error dialog appears that says PLAYGAMES LOGIN FAIL. So I have to select my user again and I cant move forward from this loop.

Any thoghts?

You need to have “Play Games” installed since WoA connects via Google Game Center.

Thanks! But I have it. I EVEN started the game from Play Games. But I continúe with the sale loop. And the game never starts…

Maybe some settings in google games ( there are couple of them in google games profile).

I am a bit clueless here as it is not reported so for buy anyone else.

It doesn’t look like a bug to me for the same very reason - it is Isolated problem.

Hi try to logout and login back to your google play in android settings. This in most cases works

Unfortunatelly, I did that severa times and doesn’t work. It continues to take me to the Google play SIGN IN loop. After I choose my account it asks me again with a dialog from the game to signin PLAYGAMES.


May you try to unistall game > delete local cache and install again?

Hi ! I found to be having the same issue… when I launch the game, it loads and then it tries to connect with play games but fail and I can’t do any further… Anyone having ideas about a solution ? Thanks

I haven’t managed to solve it yet. I have unistalled it many times but the problem persists. If any one can find a solución please rise a hand!

1 Like

Yeah, I tried it too… Tried to log off and log in with google play, tried cleaning the cache and all, but nothing is working… I desperately want to play this game xD

Can it be something due to localization ? I’m from France. I don’t think it could be this but any thoughts are good I guess…

Solved!! I didn’t do anything but now I can play! May be the recent update of Android solved it.

Try logout and login back to google play account and then start game