Not able to open game

After the update i am not able to open game,it keep crashing as i tried your method by logging out from game center and logging in back then too the game keep crashing
My phone -Iphone xs
Ios version- 14.2 beta
Please help me what should i do
Thankyou for your valueable time😊

1 Like

I have the same issue. iPad Pro 10.5, stable iOS 14.2. Game launches to brown / grey launch screen, crashes after about 5 secs. Tried signing out of and into Game Center, didn’t help

1 Like

Same here after updating my iPhone 12 pro to 14.2. Reinstalling the game didn’t help.

1 Like

Also on my iPhone X.
After updating to iOS 14.2 the game doesn’t load.

1 Like

Same issue here as well once i have updated to iOS 14.2! :cry:

1 Like

Same issue with IOS 14.2, hopefully a big updates will fix lots of issues, let’s not be like unmatched traffic control who did not update anything for over a year.

Please keep communication open about update status

Update coming within 24 hours to fix this issue

1 Like

Same here IPhone XS last update IOS 14.2 and the game it doesn’t open the screen is totally black nothing happens

I’ve had the same issue on my iPad Air 2, I’m glad I’m not the only one haha :grin:
I thought my device was just getting old :joy:

Have the same problem on iPhone XR 128Go after the last update. :sob:
Now the game is don’t want open. Black window only.

I feel like it’s an IOS issue cause I use an Android and the only time it doesn’t load is when I use the push notifications.

While the new update solved the issue of the game not loading with iOS 14.2, the new game version has an issue of planes not landing, just waiting on queue.