New downloaded WOA but stuck at initialization

iPad newly downloaded WOA, but stuck at initialization.
Tried uninstall and reinstall, won’t work.
Stuck at below screenshot:

Any advice on how to solve?

I’m like brand new device with first time WOA running. Not even having the account set up.
Could this be problem of WOA server or the device?

given the number of players that it works correctly for, I would hedge it’s a device issue, what device are you using?

iPad Pro 4th, newly acquired…

Did you find any solution? I have got the same problem…

Hi,
As someone else in a previous message, I am currently stuck on the “Player Initialization” screen since the new release of the game. I filled a bug report in the ticketing system and I got a contact with the DEV. So far, they suggested to sign out/sign in from the Apple Game Center (I use an iPad) but it does not work.

I am using an iPad (9th generation) with iOS 17.3 (The issue occurred first with iOS 17.2) and WOA 2.2.2.

Is someone else encountering the same issue with iOS currently? Do you guys have an idea to suggest?

I am still hoping for a solution from the DEVs but my ticket does not move since a couple of days…

Thanks!

I’ve had issues, specifically with LHR.
All other airports working fine, as was LHR until Weds afternoon.
It seems that as I have grown LHR (200 contracts, growing fleet), it has reached the limit.
I’m using a newly bought 256gb iPad tenth generation, but which has 3gb RAM.
The dev guys have advised that LHR when heavily developed needs 3gb or more.
As such, I can no longer play LHR unless they are able to optimise it.
When I click play on LHR, it crashes my whole game, I can’t even get into LHR at all.
So - any body struggling, it may well be linked to your RAM.

Similar issue as well now. 128 GB iPad 8th generation with 3 GB RAM and iPad OS 17.3.

Loading fine, most airports work without any problems. But once I try LHR it briefly shows WoA 2.2.2. | name | LHR and temperature at the left bottom on black background, before it crashes and returns to the home screen of my iPad.

No issue on my iPhone.

Devs are going to release optimization in 2.2.3, Kuba said it just this morning.
As for iPads im using a 7th gen 128gb and as long as i use “fast” graphics it works just fine (was told to do that by devs too)

Regarding the “Player Initialization” issue I got, it seems to be related to my home network. The game seems to download extra data from a server somewhere. The connection to this server seems to be blocked by my firewall. I solved the issue by connecting my iPad to my cell phone. Data have been downloaded via my cell phone data scheme. It worked.
DEVs suggested my to log out/log in from the Apple Game Center but it didn’t work. Since then, they did not answer my messages.
Hope this helps.

Fast graphics sorted the issue here as well. Other two options result in a crash. Thanks!

An interesting airport! I’m now at level 62, but after two or three moves Heathrow always crashes and I have to reload LHR. All other airports are working fine.