Unplayable after update

After the new update, I do not know if anybody else has the same problem like me, but hard to start the game. It shows always problem with downloading data. After like 20 times it will get me to the game, vut again problem to start Leipzig airport. After like 10 times of trying, it will get me to play the airport, but anything I want to buy new in that airport, it will kick me out of the game.

Iphone 11 pro. iOS 15.2

Seems, I’ve also have got the same problem. I’ve been playing IAD airport, but the plane was
My Phone is Android.

Same here. I got in once after the update to 1.5. Tried to switch from IAD to MCT, got the ”Oops…”. Now the game crashes somewhere during downloading. Ive tried reboot and reset. Dare I try a re-install of the game?

Ipad Pro 10, latest os.

So I had a same issue today. Updated the game yesterday night went playing today in morning worked well and then later today I tried running play again and game got stuck on Downloading data tried many times to quit and start game again didn’t help.

I did reinstall the game and now works perfectly fine tried quitting the game for 5 times just in case it would happen again and it did not.

Lmk if that helps

So I was f…ng nervous about the game. Because love it a lot and also spending some money for gold planes so devs have income and can make us happy with updates.

I reinstalled again the software update on my iphone. Now the game works perfectly.

Hope it will stay like this and nothing will happen anymore.

Until now no problems with the game (2y playing). But already solved.

So lets enjoy the game

1 Like

Works again

I’ll say I spoke too soon. As of this morning it works again. I didnt have to do anything. Maybe some behind the scenes server work had to run, with all the gold/silver airplanes going on?

Anyway, going back to farming gps…i mean sps…before attacking LEJ.

Happy new year everyone!